Unmet Dependencies while Trying to Install || Ubuntu Installation Problem

Hi everyone,

Today I was trying to install a VPN on my Ubuntu System. So when I tried installing it with:

 sudo apt-get install <whatever you want to install> 

I came across with the following problem:

<pre>Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 r-base : Depends: r-base-core (&gt;= 3.4.0-1xenial0) but it is not going to be installed
          Depends: r-recommended (= 3.4.0-1xenial0) but it is not going to be installed
          Recommends: r-base-html but it is not going to be installed
          Recommends: r-doc-html but it is not going to be installed
 rstudio : Depends: libjpeg62 but it is not going to be installed
           Depends: libgstreamer0.10-0 but it is not installable
           Depends: libgstreamer-plugins-base0.10-0 but it is not installable
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

If you are also facing a similar kind of problem, searched the net
for a while and couldn’t get a solution. Then you are at the right place.

Solution:
Just copy paste the below code:


sudo apt --fix-broken install

sudo apt-get update

I really hope this helps all the new linux users out there.